2015-09-28

PostgreSQL 入门笔记 (openSUSE)

我是在自己电脑上实验的,系统为 openSUSE 13.2。一些设置对服务器来说并不安全,读者需要自行分辨。

安装

用 Zypper 或 YaST 安装以下必需软件包:

  • postgresql-server
  • postgresql-server

推荐安装 pgadmin3 ——一个 GUI 数据库管理工具。

根据你的编程语言,如果用 PHP,则需要安装 php5-pgsql;如果用 Java,则需要安装 postgresql-jdbc。

能阅读英文文档的同学可以安装 postgresql-docs ,在浏览器中输入以下链接就可以阅读 HTML 版本的文档:

file:///usr/share/doc/packages/postgresql93/html/index.html

注意,如果安装的是 9.4.x 版本,就要把 “postgresql93”换成“postgresql94”了。 (更多…)